In CA Service Catalog UI>Service>Permissions>Groups: the EEM group can not be found.

Document ID : KB000045747
Last Modified Date : 14/02/2018
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Issue:

In CA Service Catalog UI>Service>Permissions>Groups: the EEM group can not be found.

Occurring after a CA Service Catalog(SC) upgrade and export/import it's application in EEM.

 

Environment:  

Windows/MSSQL/CA Service Catalog 14.1

 

Cause: 

In the 'export'.xml, the application name is set to "CA Service Catalog".

And this has been changed in the R14.1 environment into "Service Catalog".

 

Resolution/Workaround:

In the 'export'.xml file, rename all occurrences of "CA Service Catalog" into "Service Catalog" accordingly.

And then run the safex command again with the 'changed-export'.xml as input.

Now the EEM-UI shows your users and groups properly.

 

Commands to be used in a commandprompt:

1. cd C:\Program Files\CA\SC\EmbeddedEntitlementsManager\bin

 

2. safex -h <EEM host name> -u eiamadmin -p <eiamadmin-password> -f c:\<folder>\'changed-export'.xml