Connection error with SAP system in Load Balancing Mode

Document ID : KB000086917
Last Modified Date : 03/04/2019
Show Technical Document Details
Issue:
The SAP manager refuses to connect to a SAP System defined in uxjcs.ini

Error Message in the universe.log:
#####
|ERROR|X|SAP|pid=p.t| uxsap_bapi_connect | Cannot create connection on SAP system [xxxx/x/xxxxxx*]
|ERROR|X|SAP|pid=p.t| uxsap_disconnect | connection is NULL
|ERROR|X|SAP|pid=p.t| uxsap_bapi_request_get_en | unable to connect to [xxxx] [X] [xxxxxx*]
#####

If the RFC traces is activated. In the file dev_rfc.trc you will find following error messages :

==============================================================================================
T:5708 Error in program 'UniSapManager': ======> Connect to message server failed
Connect_PM MSHOST=s0141bel, R3NAME=PE1, GROUP=PUBLIC

LOCATION CPIC (TCP/IP) on local host
ERROR service 'sapmsPE1' unknown
TIME Tue May 13 16:16:47 201
RELEASE 700
COMPONENT NI (network interface)
VERSION 38
RC -3
MODULE ninti.c
LINE 530
DETAIL NiPGetServByName2: service 'sapmsPE1' not found
SYSTEM CALL getservbyname_r
COUNTER 5

T:5708 Error in program 'UniSapManager': ======> 

>>> RfcOpenEx ...
 Got following connect_param string: 
 TYPE=3 CLIENT=500 USER=UNIVERSE PASSWD=******* LANG=E TRACE=0 R
==============================================================================================


The SAP manager refuses to connect the SAP System.
Environment:
OS: All
OS Version: All Operating Systems on which the SAP Manager is supported
Related configuration item(s): SAP manager activated
Cause:
Configuration issue, the port definition is missing to connect to the SAP TargetServer in the services file of the host.
Resolution:
-----------------------------------------------------------------------------------------------------------------------------------------------
Add in the /etc/services (for Unix/Linux) or  in the c:\windows\system32\drivers\etc\services the following line

sapmsSID 36TS/tcp

Example :

SID: value of R3Name
TS: value of the TargetServer

In the uxjcs.ini the following settings

CLE: BELINT/S/SAP_ECC_*
.....
R3Name: IE1
......
TargetServer: 00
.......

Declare in the etc/services file following entry and save the file.

sapmsIE1 3600/tcp

If that still does not fix the issue, double check that the following parameters in uxjcs.ini are correct after consulting with your SAP admins:

GatewayHost:    devnt17
Group:             PUBLIC
R3Name:            DEV
MessageServerHost: devnt17

Additional Information:
Consult the documentation about the correct configuration in uxjcs.ini in the following link:
https://docs.automic.com/documentation/webhelp/english/ALL/components/DU_AS/latest/%20%20Dollar%20Universe%20Guides/help.htm#SAPHelp/uxjcsini.htm%3FTocPath%3DManager%2520for%2520SAP%2520Solutions%7CConfiguring%2520the%2520Manager%2520for%2520SAP%25C2%25A0Solutions%7CAdministering%2520the%2520Manager%2520for%2520SAP%2520Solutions%7CActivating%2520the%2520Manager%2520for%2520SAP%2520Solutions%7C_____2