Impossible to login via UVC if one of the LDAP instances is unreachable

Document ID : KB000085286
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
On the uvserver.log the following message appears whenever a new ldap user tries to login:

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 |ERROR| request-worker-619 | com.orsyp.central.ldap.LDAPManagerImpl | Authenticate: Cannot authenticate login: XXXX because the LDAP server cannot be reached. Unreachable server: ldapserver.domain.com:389. 
javax.naming.CommunicationException: ldaps.oc.rabonet.com:389 [Root exception is java.net.ConnectException: Connection timed out] 
at com.sun.jndi.ldap.Connection.<init>(Connection.java:211) 
at com.sun.jndi.ldap.LdapClient.<init>(LdapClient.java:116) 
at com.sun.jndi.ldap.LdapClientFactory.createPooledConnection(LdapClientFactory.java:46) 
at com.sun.jndi.ldap.pool.Connections.<init>(Connections.java:97) 
at com.sun.jndi.ldap.pool.Pool.getPooledConnection(Pool.java:114) 
at com.sun.jndi.ldap.LdapPoolManager.getLdapClient(LdapPoolManager.java:310) 
at com.sun.jndi.ldap.LdapClient.getInstance(LdapClient.java:1581) 
#######################

Patch level detected:Univiewer Management Server 6.4.01
Product Version: Dollar.Universe 6.4.01

Description :In case there are several ldap instances defined on the ldap.xml and one of them is not reachable, the login via uvc will be impossible.
Environment:
OS: All
Cause:
Cause type:
Defect
Root Cause: N/A
Resolution:
Update to the fix version listed below or a newer version if available.

Fix Status: Released

Fix Version(s):
Component: Univiewer.Management.Server
Version: Dollar.Universe 6.5.21
Additional Information:
Workaround :
N/A