Impossible to display / edit sessions deployed from a node on version < 6.6.x : "controller/atom getParent () integrity failure "

Document ID : KB000086541
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
When displaying the session via UVC (inferior to version 6.7*), a popup error message appears with the message:
############
controller/atom getParent () integrity failure 
############

In case the UVC is upgraded to 6.7.41, no popup error appears, but the session is not displayed on the screen, on this case the following kind of messages appear on the univiewer.log:

############
    at com.orsyp.api.session.SessionTree.scan(SessionTree.java:170)
    at com.orsyp.api.session.SessionTree.scan(SessionTree.java:174)
############

Patch level detected:Dollar Universe 6.6.01
Product Version: Dollar.Universe 6.6.01

Description :On a Dollar Universe node on version superior to 6.6, a session deployed / imported from a node inferior to 6.6 cannot be edited / displayed on UVC.
Environment:
OS: All
Cause:
Cause type:
Defect
Root Cause: The issue was due to the fact that the session was deployed using an Univiewer Console on a version inferior to the Dollar Universe target node.= UVMS >= DUAS
Resolution:
In order to fix this issue, you should upgrade your infrastructure to 6.7 or superior ( no need for the reference Dollar Universe nodes ), and then redeploy / reinsert again the session via UVC / uxins.
In order to do so, your target node should be at least on version 6.7.01.

Fix Status: Released

Fix Version(s):
Component: Application.Server
Version: Dollar.Universe 6.7.01
Additional Information:
Workaround :
N/A