Importing components via application owner fails with error "Error: Component_Id"

Document ID : KB000068693
Last Modified Date : 18/07/2018
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Introduction:

Problem:

Export a component from an application in Release Automation. Login to Release Operation Center (a.k.a. ROC) as a user with Role "User" with "Application Creator" privileges and try to import exported component by navigating to section Designer -> Import/Export and you will see import failing with error "Error: Component_Id", where id is the component Id been getting imported.

Environment:

Release Automation version: 5.5.2, 6.x

Cause:

When you will see review the nolio_export.log you will find below errors.

2016-04-05 18:16:33,941 [http-nio-8080-exec-10] DEBUG (com.nolio.platform.server.dataservices.services.exportimport.ExportImportServiceImpl:500) - Import artifact types to application id 32
2016-04-05 18:16:33,942 [http-nio-8080-exec-10] ERROR (com.nolio.platform.server.dataservices.services.exportimport.ExportImportServiceImpl:257) - Could not import component Default Component
org.springframework.security.access.AccessDeniedException: Access is denied

Above "Default Component" is the name of the component which had been imported into the system.

 

After reviewing the logs in detail you will noticed that this issue is coming during the import of artifact types to specific application where we are trying to import this component which is highlighted in logs one line prior to Error message.

2016-04-05 18:16:33,941 [http-nio-8080-exec-10] DEBUG (com.nolio.platform.server.dataservices.services.exportimport.ExportImportServiceImpl:500) - Import artifact types to application id 32
2016-04-05 18:16:33,942 [http-nio-8080-exec-10] ERROR (com.nolio.platform.server.dataservices.services.exportimport.ExportImportServiceImpl:257) - Could not import component Default Component

org.springframework.security.access.AccessDeniedException: Access is denied

The reason for this specific error getting generated during import is because from the system where this component had been exported it is having an mapping of component to artifact type, which resulted in "Artifact" parameters getting exported during export of the component.

Resolution:

The current privilege of the user is "Application Owner" which only allow this user to create applications without superuser access and not make him an artifact managers hence "Access Denied" error getting generated during import of associated artifact types.

There is an additional privilege i.e. "Artifacts Manager" which need to be given for this user to import components which have associated "Artifact" type parameters.
 

To give user privilege of "Artifacts Manager" login to ASAP as superuser and navigate to Administration -> User Management. Select the respective user and click on "Edit user" icon and check the box for "Artifacts Manager" privilege and save it.

Try to login to ROC and re-import the component it will succeed.

Additional Information:

For more details around User roles and permission please review below document at docops.ca.com

 

Instructions:
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