imexutil.sh and dSeries version

Document ID : KB000054729
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

imexutil.sh can operate against other dSeries servers besides the installation it belongs to. While it's highly recommended to use the imexutil.sh of it's own version to do import/export, eg. R5 imexutil.sh for R5 dSeries server, R11 imexutil.sh for R11 server, etc.

When the above rule is not followed:

  1. Using R5 imexutil.sh against R11 server doesn't produce error;

  2. Using R11 script against R5 server, the following error would be reported:
    java.rmi.ServerException: RemoteException occurred in server thread; nested exception is:
    java.rmi.UnmarshalException: invalid method hash

Solution:

It's highly recommended to use the imexutil.sh for the version for which it is meant for to do import/export, eg. R5 imexutil.sh for R5 dSeries server, R11 imexutil.sh for R11 server, etc.