ICH408I error message access to derby.log Web Viewer

Document ID : KB000104936
Last Modified Date : 09/07/2018
Show Technical Document Details
Issue:
I am investigating a RACF ICH408I msg we have across many of our Web Viewer WebSphere cells such as this in our production system : 
ICH408I USER(WPYSYS ) GROUP(WPYCFG ) NAME(DMGR DAEMON,CR AND S) 
derby.log CL(DIRACC ) FID(D7D6C5C4F4F349A100000000001D0001) 
INSUFFICIENT AUTHORITY TO OPEN 
ACCESS INTENT(-W-) ACCESS ALLOWED(OTHER R-X) 
EFFECTIVE UID(0000005403) EFFECTIVE GID(0000005400) 

We are using DB2 for our external database.

It's strange as no path is given for the location of derby.log.



























 
Environment:
WebSphere
DB2
Tomcat
Cause:
Someone must have changed the permissions on derby.log as that is a log for internal use only.
Resolution:
The derby.log is an internal database that Web Viewer is using and is located right below your Web Viewer install folder: 
Check the file ${CAOMWV12_HOME}/derby.log . The derby.log is used internally as a workarea and should not be a concern for you. It is not useful for troubleshooting.

Change the derby.log access to 777 (-rwxrwxrwx)  to resolve the RACF access error message.
 
Additional Information:
​NOTE: The derby.log was also found in the /CA_OM_Web_Viewer directory.