I installed Common Services r 14.1 and when I run CAIRIM to start CA Intertest Batch I receive messages CAMR955E and CAS9140E.

Document ID : KB000030380
Last Modified Date : 14/02/2018
Show Technical Document Details

The resolution to this case was to make sure the CA InterTest Batch CAILIB is APF authorized. If the entire CAILIB load library is not APF authorized then the client can run install JCL member MR85RTL. This JCL is located in the install PDS to copy the CA InterTest batch load modules that require APF authorization.

The MR85RTL JCL copies the following modules to the AFP library of choice.   

//AUTHLIB  DD DISP=SHR,DSN=USER.AUTHLIB
//*-------------------------------------------------------------------*
//CAILIB   DD DISP=SHR,DSN=CAI.CAILIB
//*-------------------------------------------------------------------*
//SYSIN    DD *
 COPY INDD=((CAILIB,R)),OUTDD=AUTHLIB
 S M=CAMRPROL
 S M=CAMRSCHB
 S M=CAMRSKUT
 S M=CAMRSTBZ
 S M=CAMRSVCI
 S M=CAMR40IP
 S M=MR85INIT
/*
//

 

A second possible cause of the problem could be the SVC number being used on the initialization command is not available. The following JCL can be used to see the available SVCS on the LPAR.

//CAMRSVCQ JOB                                                                   .
//**********************************************************************         .
//**                                                                  **         .
//**       THIS UTILITY WILL GENERATE A REPORT OF THE AVAILABLITY     **         .
//**       OF THE USER SVCS (SVC 200 - 255)                           **         .
//**                                                                  **         .
//**********************************************************************         .
//QUERY    EXEC PGM=CAMRSVCQ,REGION=256K                                         .
//STEPLIB  DD   DISP=SHR,DSN=CAI.CAILIB                                          .
//SYSPRINT DD   SYSOUT=*

 

A third possible cause of the problem is for Common services releases prior to release 12.0, the CA InterTest Batch CAILIB must be a PDS. Common services releases prior to R12.0 did not support the CA InterTest Batch CAILIB if it was defined as a PDSE.