I have upgraded to Common Services for z/OS v14.1 from r12. In my current CICS regions, I have a CCCSCICS library included in my DFHRPL concatenation. Is this a requirement for CA Common Services for z/OS?

Document ID : KB000013449
Last Modified Date : 14/02/2018
Show Technical Document Details
Introduction:

After an upgrade to CA Common Services v14.1 from r12.0, there is an r12.0 CCCSCICS library included in the DFHRPL concatenation of the customer's CICS regions.    

Question:

We have upgraded from V12 to V14 and we found that we have CCCSCICS dataset in our CICS region.  Now we have V12 dataset in DFHRPL and the regions are up and running.  We are running SYSVIEW and DISPATCH.  Can you please let us know if there is a requirement to have this dataset in the DFHRPL DD?  

 

 

 

Environment:
CA Common Services with the Legacy CA-C Runtime, and CA Viewpoint components installed.
Answer:

The CCCSCICS library contains modules for CA-C Runtime, and CA Viewpoint. 

This dataset is only necessary to be added to the CICS DFHRPL if directed  by a CA Product. This library is not necessary for either an ACF2/CICS or Top Secret/CICS implementation.

Additional Information:

Refer to the CA Documentation wiki for the products you may have installed in order to determine if the CCCSCICS library is required to be included in the DFHRPL concatenation.