I cannot run adapters from the GUI and they stay on "connection error".

Document ID : KB000045717
Last Modified Date : 14/02/2018
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Issue/Problem/Symptoms: 

 

I can start or stop adapters from the GUI but when I try to run an adapter from the GUI nothing happens.

The adapter stays on the default state of "connection error".

The adapter log and the system log both shows no error, so it is not a problem with the adapter config.

I can run the adapters fine by clicking the shortcut in the adapter folder.

 

Environment:  

 

Any

 

Cause: 

 

We have seen this problem occur if the adapters were scheduled and a local account (or an account with reduced rights) was specified instead of a domain account.

 

Resolution/Workaround:

 

To solve this, wipe out the current scheduling account by running:

 

update t_system_configurations set sys_config_value='' where sys_config_name like 'scheduled_adapter_%';

commit;

Then stop and restart the adapters in question. The first adapter you restart will prompt you for the account once again.

Be sure that you specify a domain account which also has local admin rights on both the APP and WEB server. This should be the same account you run most of the BSI services under.