I am upgrading to a new version of JES2. What needs to be done for CA-ACF2?

Document ID : KB000026507
Last Modified Date : 14/02/2018
Show Technical Document Details

Issue:

I am upgrading to a new version of JES2. What needs to be done for CA-ACF2?

 

Description:

If you are upgrading to a new version of JES2 and z/OS without upgrading CA-ACF2, you should reassemble and link the CA-ACF2 JES2 interface.

 

Resolution:

When upgrading JES2 and z/OS to a new level without upgrading CA-ACF2, or after applying JES2 maintenance you should re-assemble and link the CA-ACF2 JES2 interface.


The CA-ACF2 JXBUMJ2 member provided in the SAMPJCL data set can be used to apply USERMOD UMJ2999 which causes the CA-ACF2 JES2 interface to be reassembled and linked. USERMOD UMJ2999 which is located in the CA-ACF2 ACFPTFS dataset adds a dummy element to CAI.CAIMAC and explicitly assembles the CA-ACF2 JES2 security interface modules: ACFJ2ITF, ACFJ2USR, ACFRJES2, AND ACFUJES2.