I am unable to add a display condition to a subpage. The [Define display conditions] link is missing at the Subpage Properties. Why?

Document ID : KB000076792
Last Modified Date : 13/04/2018
Show Technical Document Details
Issue:
Steps to reproduce:
Let use the Project Summary subpage as an example
1. Go to Administration > Studio > Objects > Project object 
2. Go to Views > Project Properties > Layout:Edit
3. Click on the Project Summary Subpage properties icon
4. At the Display Conditions section, you see the [Define display conditions] link.
User-added image
5. Create the following Display Condition (where the subpage will be displayed if the user who is logged in belongs to the specific user group): Check Resource's Group = 'Application Administrator'
User-added image
6. Go to Administration > Organization and Access > Groups
7. Locate the 'Application Administrator' group and Deactivate it
8. Go back to the Project Summary Subpage properties icon in step 3 and check the Display Conditions section
User-added image
Expected Result: The display condition to be visible or the [Define display conditions] link to be accessible
Actual result: The [Define display conditions] link is not visible and I cna not add a new display condition.
Resolution:
This is the expected behavior: The Display condition that was initially set is not valid any longer.
Click on the Delete button and create a valid condition.
Additional Information:
Alternatively, check at DB level what the display condition is and ensure it gets validated or create a new one as required.
The following query will allow you to identify the Display Conditions at DB level:

SELECT exp.object_instance_id, v.object_code, v.caption, v.view_type, 
v.link_code, exp.expression, v.partition_code 
FROM odf_filter_expressions exp, odf_views v 
WHERE exp.object_code = 'ODF_VIEW_CONDITION' 
AND exp.OBJECT_INSTANCE_ID = v.id 

The same theory applies to process auto-start conditions. Please check the below KB:
kb000077674