HTTPS protocol can't open CA Service Catalog(SC) form correctly

Document ID : KB000005229
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Environment running CA Service Catalog and CA PAM with Service Desk integration.

We have Catalog Form requests which open CA Service Desk tickets (via PAM automation).

Every thing works correctly using HTTP protocol for access CA Catalog forms.

We have a CA Service Catalog form which presents some combo boxes in some predefined fill arrangements.

But, when using HTTPS protocol, some of the combo boxes (for the same CA Catalog forms) do not appear.

 

Environment:
Windows running CA Service Catalog.
Cause:

The encoding is missing for HTTPS.

Resolution:

Please open your server.xml file in folder %USM_HOME%/view/conf.

For the HTTPS connector please enable encoding by adding the below attribute: 

URIEncoding="UTF-8"

 

Example (remove the comment-lines when you activate HTTPS):

<!-- 

Define a SSL HTTP/1.1 Connector on port 8443 

-->

<!--

 

<Connector port="8443" URIEncoding="UTF-8" enableLookups="false" tomcatAuthentication="false" maxHttpHeaderSize="20480"

 maxThreads="400" minSpareThreads="25" maxSpareThreads="100" debug="0" connectionTimeout="15000"

      disableUploadTimeout="true" compression="on" compressionMinSize="2048"

      compressableMimeType="text/html,text/plain,text/xml,text/css,text/javascript,image/png,image/gif,image/jpeg,application/json"

      scheme="https" secure="true" clientAuth="false" sslProtocol="TLS" SSLEnabled="true"

      keystoreFile="C:\Program Files\CA\Service Catalog\.keystore" keyAlias="alias_name" keystorePass="changeit"/>

    

-->

 

Additional Information:

Consider to 'clear' and restart the environment:

- Stop the CA Service Catalog services(Accounting and Catalog)

- Empty/clear the %USM_HOME%\view\translets folder

- (re)move the %USM_HOME%\logs\*.log files

- Clear the browser-cache

- Start the CA Service Catalog services(Accounting and Catalog)