HTTP/1.1 401 Unauthorized error running CA Performance Management Top N report in CABI 6.3

Document ID : KB000008067
Last Modified Date : 14/02/2018
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Issue:

HTTP/1.1 401 Unauthorized error running CA Performance Management Top N report in CA Business Intelligence Jaspersoft Reports Server 6.3.

Environment:
CA Performance Management 3.2,CABI 6.3.0
Cause:

Authentication tokens have a default timeout value of 20 mins and if the system clocks on CA Performance Center and Data aggregator servers are not in Sync following error is seen

used by: net.sf.jasperreports.engine.JRException: Unable to load schema version:net.sf.jasperreports.engine.JRException: Response is HttpResponseProxy{HTTP/1.1 401 Unauthorized [WWW-Authenticate: Basic realm=OpenAPI, Content-Type: text/html;charset=iso-8859-1, Cache-Control: must-revalidate,no-cache,no-store, Server: Jetty(8.1.17.v20150415), Content-Length: 1397] ResponseEntityProxy{[Content-Type: text/html;charset=iso-8859-1,Content-Length: 1397,Chunked: false]}} at com.ca.capm.jasper.datasource.metadatautils.MetadataKeeper.getSchemaVersion(MetadataKeeper.java:103) at com.ca.capm.jasper.datasource.metadatautils.MetadataKeeper.<init>(MetadataKeeper.java:48) at com.ca.capm.jasper.datasource.metadatautils.MetadataKeeper.getInstance(MetadataKeeper.java:58) at com.ca.capm.jasper.datasource.query.CAPMQueryExecuter.getDataSourceOfType(CAPMQueryExecuter.java:94) at com.ca.capm.jasper.datasource.query.CAPMQueryExecuter.createDatasource(CAPMQueryExecuter.java:72) 

Resolution:

Clocks on CA Performance center and Data aggregator servers need to be in sync.