HTTP 500 internal server error after logging into WCC.

Document ID : KB000047282
Last Modified Date : 14/02/2018
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Issue/Problem/Symptoms: 

When logging into WCC we get an HTTP 500 internal server error message.

Following error message are find back in CA-wcc.log after starting CA-wcc service.

INFO | jvm 1 | 2016/10/04 09:58:00 | 16 | @tomcat-resource <WrapperStartStopAppMain> [] ERROR #EmbIAMAccessProvider # EmbIAMAccessProvider - SafeContextFactory.getSafeContext failed for config: AccessConfig[HostName=lxautosysd01.conseco.ad, Locale=en_US, ServerEnabled=true, AppName=WCC0004, AppCertPath=/app/CA/WorkloadCC/data/config/wcc.pem, ServerAdminID=EiamAdmin, EventLogPath=null, PersistentCachePath=null, RetryConnectInterval=30, RetryPingInterval=30, FullCacheUpdateEnabled=false, CacheUpdateInterval=30], SafeException.getMessage = EE_AUTHFAILED Authentication Failed 

INFO | jvm 1 | 2016/10/04 09:58:00 | 16 | [Authenticate Error: Authentication Failed, Identity Attempted: null] 

INFO | jvm 1 | 2016/10/04 09:58:00 | 16 | com.ca.eiam.SafeException: EE_AUTHFAILED Authentication Failed 

.... 

.... 

.... 

INFO | jvm 1 | 2016/10/04 09:58:00 | 16 | Oct 04, 2016 9:58:00 AM com.ca.wcc.access.resources.BaseAccessProviderFactory getObjectInstance 

INFO | jvm 1 | 2016/10/04 09:58:00 | 16 | SEVERE: Access Configuration = AccessConfig[HostName=lxautosysd01.conseco.ad, Locale=en_US, ServerEnabled=true, AppName=WCC0004, AppCertPath=/app/CA/WorkloadCC/data/config/wcc.pem, ServerAdminID=EiamAdmin, EventLogPath=null, PersistentCachePath=null, RetryConnectInterval=30, RetryPingInterval=30, FullCacheUpdateEnabled=false, CacheUpdateInterval=30] 

INFO | jvm 1 | 2016/10/04 09:58:00 | 16 | Oct 04, 2016 9:58:00 AM com.ca.wcc.access.resources.BaseAccessProviderFactory getObjectInstance 

INFO | jvm 1 | 2016/10/04 09:58:00 | 16 | SEVERE: Error creating EEM access provider. 

 

INFO | jvm 1 | 2016/10/04 09:58:00 | 16 | java.lang.RuntimeException: could not establish the context 

 

Environment:  

CA Workload Control Center 11.4 

Cause: 

Certificate has been corrupted.

Resolution/Workaround:

Regenerate certificate using keytool certificate.

Additional Information:

 

You can find more information on generating certificate on docops.ca.com

See also https://docops.ca.com/ca-wla-ae-wcc/11-4-2/en/installing/ca-wcc-implementation/customizing-secure-access-to-ca-wcc#CustomizingSecureAccesstoCAWCC-ChangingtheCertificate