HTTP 404 Error when viewing Spectrum Report Manager parameters

Document ID : KB000039436
Last Modified Date : 14/02/2018
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Problem: 

 

When right clicking on any report in the BI Launch Pad for Spectrum Report Manager a HTTP 404 error is seen.

 

Environment:  

Any Operating System is affected

 

Cause: 

 

This error is generally fixed by D08a for Spectrum 10.0.

D08a was included in 10.1 as well.

Post Install steps are required after installing that patch.  The same steps are required on 10.1 as well.

See http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/tec1258996.aspx

After performing the steps, the 404 error is still seen.

The problem is due to a web.xml file not getting properly updated in the process.

 

Resolution/Workaround:

 

1. Navigate to $BO_INST_PATH/CommonReporting4/tomcat/webapps/BOE/WEB-INF/eclipse/plugins/webpath.CustomParams/web/WEB-INF/

2. Open the web.xml file in a text editor.

3. Find the section:

 

 

<context-param>

  <param-name>xmlFilePath</param-name> 

  <param-value>/opt/CA/SharedComponents/CommonReporting4cacaf</param-value>

  </context-param>

Note the "CommonReporting4cacaf".

This should be separated with a slash.

 

4. Update that line to look like this:

  <param-value>/opt/CA/SharedComponents/CommonReporting4/cacaf</param-value>

5. Save the file and exit.

6. Shutdown CABI Tomcat.  On Windows you will utilize the Central Configuration Manager.

On Linux go into $BO_INST_PATH/CommonReporting4/sap_bobj/

Execute:  ./tomcatshutdown

7. Next, do not start CABI Tomcat yet.  Go into $BO_INST_PATH/CommonReporting4/tomcat/work/Catalina/

8. Delete the entire localhost directory structure.

9. Start CABI Tomcat back up.

Windows utilize Central Configuration Manager again.

Linux: ./tomcatstartup (from the same sap_bobj) directory as above.

10.  Issue should be resolved.