hrefresh not working correctly

Document ID : KB000103172
Last Modified Date : 29/06/2018
Show Technical Document Details
Issue:
R13. Hrefresh as post-link UDP is not placing files on remote agent machine.error in hrefresh log files: 

I00060040: New connection with Broker <brokername> established. 
Unable to find appropriate Checkout process. 
The checkout to <clientpath> on <agentname> failed with error code 3. 

There are two check out processes available. both are 'public' access.
Cause:
CA Harvest SCM all versions and platforms
Resolution:
i found my error. I am using a production environment broker but the remote agent is in a QA environment. The production service account does not have access to the QA environment remote agent login. 
I have used the correct level logins for testing and Hrefresh is working correctly