HQ119015: The connection was disconnected because of server shutdown [code=DISCONNECTED]"

Document ID : KB000126723
Last Modified Date : 12/02/2019
Show Technical Document Details
Issue:
Discovery server showing following warning "28 Jan 2019 12:23:38,679 [Thread-73 (HornetQ-client-global-threads-933869191)] WARN org.hornetq.core.client - HQ212037: Connection failure has been detected: HQ119015: The connection was disconnected because of server shutdown [code=DISCONNECTED]"

 
Environment:
Any UIM 8.x and 9.x
Cause:
When the queue exceeds the threshold (queue_growth_size = 10 MB default), an alarm is sent.
Resolution:
Goto hub.cfg file, check for "queue_growth_size =" but the default is 10MB. This is the hub bulk warning in the hub.cfg Alarm on queue size - the size of the queue file (in MB) on the hub. If the queue exceeds this threshold, an alarm is sent.  As a best practice support suggest this value be raised to a minimum of 300. In large environments, this should usually be 500 - 750.
Additional Information:
https://docops.ca.com/ca-unified-infrastructure-management-probes/ga/en/alphabetical-probe-articles/hub/hub-im-configuration/hub-im-gui-reference#HubIMGUIReference-GeneralAdvancedSettings