How to resolve error message "DB90152E - DATACOM PARM SYNTAX ERROR (A)"

Document ID : KB000045634
Last Modified Date : 14/02/2018
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Issue:              

When running the CAIRIM (CAS9) process for CA Datacom version 15.0, the process for the control statements ends with an Init error and RC=0008, and displays a message about SYNTAX ERROR(A):

CAS9115I - Input: PRODUCT(CADATACOM) VERSION(BD15) INIT(DBCR5PR) LOADLIB(…)
DB90150I - DATACOM DBCR5PR 2013/12/05-1359 15.0
DB90152E - DATACOM PARM SYNTAX ERROR (A)
DB90153E - DATACOM INITIALIZATION FAILED
CAS9140E - INIT ERROR: CADATACOM VER BD15, INIT ROUTINE RC=0008

Environment: 

This applies to CA Datacom/AD and CA Datacom/DB at version 15.x.

Cause:

In version 15.0, the process of initialization was simplified. Version 14.x loaded two programs - DBPCCPR and DBPCSPR, and in version 15.x, the functionality was rolled into one program - DBPCCPR.

Resolution:

The SYNTAX ERROR (A) is typically caused by not having the correct control statement, and may be the result of deleting the wrong set from a previous version 14.x configuration, or from having an error in the PARM field.

Be sure that you are referencing the PCC module as shown here:

PRODUCT(CA DATACOM) VERSION(BD15) INIT(DBCR5PR)  -
LOADLIB(…your CA Datacom CABDLOAD or CAAXLOAD…)  -
PARM(PC=PROD,PCC=DBPCCPR)

As always, please contact CA Technologies support for CA Datacom if you have further questions.

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