How to prevent the Workflow Task Service Type to be in status "Not Active" on a Change Order

Document ID : KB000017400
Last Modified Date : 14/02/2018
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Issue:

When a new Change Order has a Category which contains a Service Type assigned to the Workflow Tasks, the Status Delay for this Service Type show as "Not Active"

Steps to reproduce:

  1. Create a new Service Type (or edit an existing one)
  2. To the new Service Type, add a new Service Type Event with Object Type "Workflow Task" in the 'Change Order Tasks' Tab
  3. Next step is to edit an existing or create a new Category and in the 'workflow' Tab, add a new Workflow Task (i.e. 'Approval')
  4. Click on the Task 'Approval' to Edit it
  5. Set the new Service Type created on step 1 to the Approval Task and save the Category
  6. Open a new Change Order and set the Category from step 3 and save it
  7. Go to the Change Order Detail, in 'Additional Information' > 'Workflow Task' Tab you can see the 'Approval' Task set to the Category Service Type
  8. Click on the 'Approval' task
  9. The unexpected behavior is that in the Task detail, the 'Delay Status' is as 'Not Active'

Check the images below:

Figure 1

Figure 2

Figure 3

Figure 4

Figure 5

Environment:

Service Desk 12.7, 12.9

Cause:

The classic_sla_processing option is 'Installed'

Resolution:

To change this behavior and make the Workflow Task Service Type active, do the following:

  1. Check if the option in Options Manager, 'classic_sla_processing' is as 'Installed'
  2. Uninstall this option and restart the Service Desk Services
  3. The behavior will change and the next Change Order will show the 'Delay Status' as 'In Progress' in the Task Detail
  4. This way the Service Type for WF Tasks will be processed

    Figure 6

    Figure 7