How to Modify transfer JCL for CA XCOM Data Transport 12.0 after implementing TLS V1.2 support?

Document ID : KB000014775
Last Modified Date : 14/02/2018
Show Technical Document Details
Introduction:

We need to have everyone use TLS V1.2 with XCOM.  

 

Question:

Is there a possible way so that we would not have to have all of our batch jobs updated?

 

Are there parameters that I can set in the config file that will make this happen?

Answer:

Yes, you avoid updating all your JCL. 

  • Use SSL=ALLOW in the config file if you plan to run ANY SSL/TLS transfers.
  • Use SSL=ONLY to disallow non-SSL/TLS transfers altogether. 


As long as you use SystemSSL (a requirement for using TLSv1.2 on z/OS), even the non-SSL port will convert the conversation to use SSL if it is requested by the partner.