How to create a derived universe in CA Business Intelligence from CA ServiceDesk universe?

Document ID : KB000053418
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

This document explains the procedure for creating a derived universe which can be used for promoting schema changes in BOXI.

Solution:

The following are the guidelines for CA ServiceDesk Universe

  • Do not modify the default development CA Service Desk universe installed with CA BI.

  • Maintain the z_ naming convention for the universe file name on all derived universes.

  • Use the CA Service Desk connection, then store the universe in the CA Customer Universe folder.

Steps to create a derived universe

  1. Open the Business Objects Designer and login as Administrator.

  2. Click on File->New and the Universe Parameters window appears.

  3. In the Definition tab, enter a name for the derived universe. Figure 1

    Figure1
    Figure 1

  4. Enter the Description for the universe (Optional)

  5. In the Connection drop down, select CA ServiceDesk Figure 2

    Figure2
    Figure 2

  6. Go to Links tab, click on Add Link. Figure 3

    Figure 3
    Figure 3

  7. In the Universe To Link dialog box, navigate to CA ServiceDesk universe. Figure 4

    Figure 4
    Figure 4

  8. Click OK to close the Universe Parameters box. Designer may take few minutes to save the link and create the derived universe.

  9. Designer will open the derived universe in the Designer. Figure 5

    Figure 5
    Figure 5

  10. Select File->Parameters->Parameters tab. Select the parameter ANSI92, in the value field enter Yes and click on Replace button. Figure 6

    Figure 6
    Figure 6

  11. Go to the Controls tab and change the values for the parameters appropriate to your implementation. Figure 7

    Figure 7
    Figure 7

  12. On the menu bar, click on Tools->Hierarchies

  13. Select the custom hierarchies if any then click on Add arrow to move the hierarchies to the right side. If there are no custom hierarchies, leave the default settings Figure 8

    Figure 8
    Figure 8

  14. Click on File->Save and the Save As dialog box appears.

  15. In the File name field, enter a file name starting with 'z_' and save to the same folder which has the CA ServiceDesk universe. Figure 9

    Figure 9
    Figure 9

  16. The derived universe need to be exported to CMS to make it available. Select File->Export, from the Domain drop down click on Browse and locate the CA Universe folder.Figure 10

    Figure 10
    Figure 10

  17. Click on OK to upload the universe to the CMS. A message "Universe successfully exported" is displayed.

  18. Login to Infoview as Administrator

  19. Select Public Folders->In the infoview tool bar click New->Folder Figure 11

    Figure 11
    Figure 11

  20. Enter a Folder name and click on Ok. This creates a folder where the custom reports created using the derived universe can be stored. Figure 12

    Figure 12
    Figure 12