How to Configure Autosys r11.3.6 SP1 to use Java 1.7.0_x

Document ID : KB000010197
Last Modified Date : 14/02/2018
Show Technical Document Details
Introduction:

To stay in compliance, it may be necessary for you to upgrade your Java version. This KB will show you how to point Autosys, WCC and EEM to Java 1.7.0_x.

Environment:
CA Workload Automation AE r11.3.6 SP1CA Workload Control Center r11.3.6CA Embedded Entitlements Manager r12.51
Instructions:

========= 

AUTOSYS 

========= 

1. Navigate to your $AUTOUSER directory 

2. For each of the environment host scripts you use (autosys.sh.hostname, autosys.bash.hostname, etc), open the file using an editor 

3. Find the 'Set JAVA_HOME and JRE environment' section 

4. Update the paths to reflect the updated Java version 

5. Save the file(s) 

6. Source the environment host script of your choice 

 

========= 

WCC 

========= 

1. Download and save the jre 1.7.0_x installer in the $CA_WCC_INSTALL_LOCATION directory 

2. Navigate to the $CA_WCC_INSTALL_LOCATION directory 

3. Run the installer (this should create a directory called jre1.7.0_x) 

4. Stop WCC services 

5. Rename the current jre directory to jre_1.7.0_17 

6. Rename jre1.7.0_x to jre 

7. Restart WCC services 

 

========= 

EEM 

========= 

1. Download and save the jre 1.7.0_x installer in the EEM installation directory 

2. Navigate to the EEM installation directory 

3. Run the installer (this should create a directory called jre1.7.0_x) 

4. Stop the dxserver and igateway services 

5. Rename the current jre directory to jre_1.6.0_25 

6. Rename jre1.7.0_x to jre 

7. Restart dxserver and igateway services