How to capture a MIB dump of a device with OneClick MIB Tools (Legacy KB ID CNC TS21900 )

Document ID : KB000052046
Last Modified Date : 14/02/2018
Show Technical Document Details

This procedure describes how to capture a MIB dump of a device with JMibTools or the new 8.1 OneClick MIB Tools. The MIB dump can be used to simulate the device by SPECTRUM Technical Support for testing purposes.


 


A MIB dump of a device is the output of a SNMP walk through the entire MIB tree.  The terms MIB dump, MIB walk, SNMP snapshot and simulation are used synonymous for the purpose of this document.


 


Up to version 8.0 of SPECTRUM,  JMibTools can be used as follows:


 


    From SpectroGRAPH select Tools -> MIB Tools.


    Under the Preferences tab, set Retry Count to 3 and TimeOut to 5.


    Under the Browser tab, enter the IP and community name for the desired device and establish contact.


    In the tree window select the "internet" folder (top most folder)


    Ensure the query window is cleared or AutoClear is checked and start the query.


    When the query is complete, select the File/Save Table To File menu option and save the results.


For more information on JMibTools see SPECTRUM Documentation JMibTools - Docum.ent 1426. 


With SPECTRUM 8.1 new MIB Tools have been introduced:


 


    From OneClick, launch MIB Tools (Tools -> Utilities -> MIB Tools?).


    Enter Contact Criteria (Device IP, SNMP Version, Community String).


    The SNMP port can be changed under Advanced Options if necessary.


    Click the Contact Button to contact the device.


    In the hierarchy window select the "internet" folder.


    Ensure the results window is cleared or the AutoClear checkbox is checked .


    In the hierarchy window start the query (GET NEXT ? second button from left).


    When the query is complete, click the Export button (most right button in results window).


    Give a meaningful name and save as "Simulation" (.sim).


    If necessary click "Advanced Options" button and increase Retry Count and Timeout .


If not all device information can be accessed with one community name/string, repeat the steps and save each result set to its own file.

.

Related Issues/Questions:
How to capture a MIB dump of a device with JMibTools / OneClick MIB Tools

How to capture a MIB walk of a device with JMibTools / OneClick MIB Tools
How to capture a SNMP snapshot of a device with JMibTools / OneClick MIB Tools
How to capture a simulation of a device with JMibTools / OneClick MIB Tools

Problem Environment:
SPECTRUM
JMibTools
MIB Tools
OneClick

Additional Information:



(Legacy KB ID CNC TS21900 )