How the Chance Order (CO) sequence is the generated in the CHG_REF_NUM table when using Advance Availability (AA)

Document ID : KB000098158
Last Modified Date : 01/06/2018
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Issue:
It's possible to notice that in a co list, the sequence of the change order ID does not match to their open date.
 
COOpen Date
117589/3/2017 3:43
117579/4/2017 7:38 >> 1 day difference of CO 11758
130552/8/2018 5:19
130532/9/2018 10:52 >> 1 day difference of CO 13055
130942/15/2018 5:41
130932/16/2018 9:36 >> 1 day difference of CO 13094
131842/24/2018 8:26
131832/26/2018 9:07 >> 2 day difference of CO 13184
Environment:
CA Service Desk Manager 14.1 / 17.1
Cause:
The reason why this occurs is because rather than have all servers go to the database to get the next ID or next ticket number, they instead get a range of numbers and this reduces the number of times they need to go to the database.

For example, for IDs, each server asks for a range of 50. And for ticket numbers, the range is 2. These numbers are hard-coded.

Maybe they should be made configurable, so that is why I am suggesting an Idea so that it can be reviewed further.
This problem was not in 12.7 because in 12.7 all servers would go via one single bpvirtdb_srvr process but now in 12.9 and forward, each APP server has its own bpvirtdb_srvr process.
If they want to see the ID values and how it changes over time, they can look at the kc table.
Resolution:
This is an expected behavior as per the product design when working in AA

 
Additional Information:
USP Tables - KPI