How do I get my hub to see a robot through Network Address Translation (NAT)?

Document ID : KB000034301
Last Modified Date : 14/02/2018
Show Technical Document Details

Problem:

How do I get my hub to see a robot through Network Address Translation (NAT)?

Customer was unable to connect the hub to a remote robot in a NAT'ED environment.

 

Environment:  

General information applicable to most UIM versions.

 

Cause: 

NAT is not considered in hub configuration hence communication paths fail.

 

Resolution:

Enter the Network Aliases for NATTED environment by going to the hub configuration GUI.
Go to the Name Services Tab.
Click on NEW in the Network Aliases section.
Enter the From/To IP addresses and restart the hub. 
 
**Note**

From=Physical IP address of the remote hub/robot
To=NATTED IP so that the hub can talk back.

Keep in mind that when restarting the hub, it will take a few minutes to come back online.

 

Additional Information:

HUB name services information

HUB probe article