How do I do a Clean Uninstall of the PPM MSP Interface?

Document ID : KB000045862
Last Modified Date : 17/05/2018
Show Technical Document Details
Introduction:
Sometimes, due to permission restrictions or other issues on the machine, some of the MSP components do not get uninstalled on their own. If that is the case, a manual uninstall is needed to remove the remaining components. Doing a clean uninstall / install is especially recommended if running into issues during an upgrade of the MSP Interface. 
Question:

How do I do a Clean Uninstall of the CA PPM Microsoft Project (MSP) Interface?

Answer:

Below are the steps to do a clean uninstall:

1. Uninstall the following components from Control Panel:

  • CA PPM Microsoft Project Interface 
  • CA PPM Schedule Connect
  • CAClarityAddin
  • Open Workbench (if installed) - Note, prior to uninstalling OWB, if you have any custom views for OWB, make sure to save these in a separate folder prior to the uninstall. 
Screen shot of the CA PPM MSP Interface programs to uninstall

2. Clean out the Registry:

  • On the workstation, go to Start and type 'regedit' in the search field. Select regedit.exe
  • Select File -> Export and enter a File Name to store the back-up of the registry
  • Once finished creating a backup, delete the following keys if they exist: 
    • HKEY_CURRENT_USER\Software\Niku
    • HKEY_LOCAL_MACHINE\Software\Niku (You may need to drill down to the Wow6432 folder to get to the Niku folder: HKEY_LOCAL_MACHINE\Software\Wow6432Node\Niku)

Please note that some of the keys may not exist; also, deleting each key will correctly delete all of their sub keys. 

3. Go to Add/Remove Programs again and check that there is no trace left of the products that you have removed in step 1

4. Delete the following folders if they are still listed: 

  • C:\CA\CA PPM MSPInterface
  • C:\CA\PPM Setups
  • C:\CA\PPM\CA PPM Schedule Connect

Please note that the folder location is dependent on where the MSP Interface was installed:

  • If you installed the 32 bit Interface, the folders may be instead found in: C:\Program Files (x86)
  • If you installed the 64 bit Interface, the folders may be instead found in: C:\Program Files

5. Clean out Visual Basic:

  • In MSP, go to View > Macros > Visual Basic Editor
  • Expand ProjectGlobal, Expand Modules
  • Delete the modules that start with either CA_ and Niku_ (Right click the module and select 'Remove ...' (Example below)

image2016-6-29 10:46:18.png

  • Click ‘No’ to the message that pops up ‘Do you want to export <Module Name> before removing it?’
    –(That is asking if you want to export the files, which is not needed)

image2016-6-29 10:46:44.png

  • Expand Microsoft Project Objects, Double-click on Thisproject
  • Select everything in the right panel and delete it
  • Save and exit VB

 6. Verify the correct Trust Center Setting is set:

  • Go to File > Options> Trust Center > Trust Center Settings
  • Make sure "Enable all macros" is selected

7. Reinstall the MSP Interface.

  • Ensure the bit level of the MSP Interface being installed matches that of MSP.
  • Also make sure the version being installed is the same version and patch level as that of PPM. It can be found in PPM by going to Home->Account Settings->Software Downloads.
8. If using a proxy, reenter the Proxy Host and Proxy Port in the setup window in MSP. See the steps to renter proxy details found in KB: KB000072865
Additional Information:

For steps on how to do a Clean Uninstall of Open Workbench (OWB): TEC1651388
Reference KB000071385 - CA PPM and MSP integration - List of Knowledge Documents
Reference KB000015956 - CA PPM and MSP integration known defects - Support Technical Document Index