How can I get past the CA Client Automation installation message Warning: this platform has not been validated for CA ITCM on UNIX based machines

Document ID : KB000045257
Last Modified Date : 14/02/2018
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Issue:

During the installation of CA Client Automation on a non certified UNIX based Operating System or a machine
that falls under the compatible Linux Variant Support statement you receive during the interactive install this message:

agent]# ./installdsm

Preparing interactive install, please wait...

Warning: this platform has not been validated for CA ITCM, but installation will continue because an earlier version of the

operating system has been validated. Please be aware that if you continue there may be problems during later stages of this installation.

 

Environment:  

CA Client Automation - All Versions

Non Certified UNIX based Operating System or a machine that falls under the compatible Linux Variant Support statement.

 

Cause: 

The cause of the error is a part of the installation script that checks the kernel and or operating system is unrecognized and will generate the install Warning.

 

Workaround:

Prior to running ./installdsm on these systems you should set and export the following system environment variable

DSM_IGNORE_PREREQ=YES

export DSM_IGNORE_PREREQ

 

Then rerun the ./installdsm and it may display the message but continue on. If you have further issues you should try this

1. clear out the /tmp folder of CA Client Automation installation logs

2. run this to set and export the debug flag for the installation:

export ITRMDEBUG"=""-x" 

 

This writes its logs to the ca-dsm#####.log located in the /tmp directory there may be other files that support
would need to see from the /tmp and those should be included when opening a CA Support Issue. 

 

Additional Information:

CA Support Statement for Running CA Client Automation (formerly known as CA ITCM) on Compatible Linux Variants

CA Client Automation Compatibility Matrix