History Query showing multiple days when 'Current Day' selected

Document ID : KB000084555
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
N/A

When performing a History Query and leaving the Current Day option checked, multiple days are displayed. See the screenshot below.
 
0EMb0000001QhUV.png

The Applications Manager (AM) documentation states that the 'Current Day' checkbox returns data from the current calendar date and will only show results from midnight to the current time.  In the above case the results are displaying jobs that completed over 36 hours ago. 

The value for the 'Current Day' option is not the physical 24 hour day, but the Virtual Day.  When you run a query and select that box it will return everything from the Virtual Day range.  If there is something wrong with the Virtual Day, you may see results similar to those described above.

Investigation

To determine if there is something wrong with the Virtual Day, you would need to enable RmiServer debugging and look for an exception in the RmiServer debug logs  at some point between when the RmiServer was restarted and the current time as long as it included a Virtual Day set.  

Reference

User Guide > Querying and Filtering Explorer > Querying for Tasks in History

Cause:
Cause type:
Defect
Root Cause: The documentation does not match the behavior for the "Current Day" checkbox.
Resolution:
Update to fix version listed below.

Fix Status: Released

Fix Version(s):
Applications Manager 9.1 - Available
Additional Information:
Workaround :
Restart the RmiServer process to reset the Virtual Day.