The Help menu cannot be opened in 17.1

Document ID : KB000112618
Last Modified Date : 10/01/2019
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Issue:
After an upgrade from 17.0 to 17.1, the online help cannot be opened anymore. Either the page will not load, or you may receive an error like "No Topics Found"
This happens when accessing the Help option or the "Help on This Window" option from CA SDM UI in a newly installed or upgraded 17.1 environment.
Error message: "The webpage cannot be found"
Environment:
USRD 17.1
Cause:
The underlying URL points to the 17.0 docops, which do no longer exist
Resolution:
You must follow the post install steps as outlined here:

https://docops.ca.com/ca-service-management/17-1/en/installing/post-installation-tasks/ca-service-desk-manager-post-installation-tasks#CAServiceDeskManagerPostInstallationTasks-UpdatetheMinorVersioninNx.Envfile
 
  1. Navigate to the $NX_ROOT folder.
    1. Open the NX.env file in a text editor.
    2. Find the parameter NX_MINOR_VER.
    3. Modify the value from 0 to 1
  2. Navigate to the $NX_ROOT\site folder.
    1. Open the install.properties in a text editor.
    2. Find the parameter genfact.gx_minor_ver.
    3. Modify the value from 0 to 1
  3. Restart the CA Service Desk Manager service.