CA PPM Health Report - slow performance and timeout due to DBLINK setup

Document ID : KB000104061
Last Modified Date : 03/07/2018
Show Technical Document Details
Issue:
I am going to CA PPM UI - Administration - Health Report, the page is spinning and spinning and eventually times out, what can I do?
 
Cause:
Check the app-ca.log, and see if you do not see a problem with your DB LINK such as the following:
 
ERROR 2018-06-28 13:08:22,695 [https-jsse-nio-443-exec-395] providers.DWHDBHealthReportProvider (clarity:admin:13381417__72DFC4BC-7A29-434D-B5EF-DC01EAFB7CEB:nmc.healthReport) Error validating dblink :PPMDBLINK
com.niku.union.persistence.PersistenceException:
SQL error code: 12154
Error message: [CA Clarity][Oracle JDBC Driver][Oracle]ORA-12154: TNS:could not resolve the connect identifier specified
 
Executed:
SELECT count(1) dblinkvalid from dual@PPMDBLINK
 
Resolving the link makes the application retry the connection many times which could lead to timeout.
 
Resolution:
Connect to your CSA and ensure your DBLINK is correctly set up. To do that, go to Server - Data Warehouse and hit Save on the page twice.
 
Once done, see if the link works, run this query on your DWH database with query analyzer:
SELECT count(1) FROM SRM_RESOURCES@PPMDBLINK
 
If it still does not work, check with your DBA to configure and troubleshoot the link as per the instructions in our documentation.