Harvest SCM - 'New broker connection' doesn't work

Document ID : KB000118913
Last Modified Date : 02/11/2018
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Issue:
In Harvest workbench, On clicking "New broker Connection", nothing happens. It stands still. Renaming/deleting .casm folder also doesn't work.
Environment:
CA Harvest SCM v12.5
Cause:
Learned that we had first installed the SCM v13 client, then found it was not compatible with a SCM v12.5 broker.  We uninstalled the SCM v13 client (but not the Enterprise Communicator) and then installed the SCM v12.5 client.  The result was that we had the wrong version of Enterprise Communicator and it was incompatible.

The thing we did during troubleshooting that gave us the clue that this might be the problem is that we tried to execute the hgetusg command line utility.  It returned the following error:  "The procedure entry point ??5TipcMsg@@UEAAEAV0@AEAPEAJ@Z could not be located in the dynamic link library rtcxxipcd64.dll"

The name of the dll mentioned in the error message starts with "rt" indicating that it is related to the Enterprise Communicator component.
Resolution:
  1. From Control Panel -> Programs we uninstalled first "Enterprise Communicator" and then "CA SCM Client". 
  2. We deleted the "C:\Program Files\CA" folder AND the "C:\Program Files (x86)\CA" folder.  
  3. We rebooted the computer.
  4. We installed the SCM Workbench Only client again
  5. We rebooted the computer again.

After this the problem was resolved.