Harvest Eclipse Plugin

Document ID : KB000110228
Last Modified Date : 09/08/2018
Show Technical Document Details
Issue:
I’m working to get a customer working in Eclipse and the user is getting an error that they cannot log into the broker (error below).  I have checked that the hosts file is updated properly, the user can log into the Workbench outside of Eclipse without incident or error and that the correct version of the plug-in that supports this version of Eclipse was supplied for SCM 13.0.0.28.  Now, I’m looking for guidance on what you think the problem could be. 

Unable to log into broker <brokername>. 

Unable to initialize CA Harvest SCM. Please ensure that all required components are installed. 
Environment:
CA Harvest SCM client or workbench-only client
Windows operating system
with Java and Eclipse installed
Cause:
The first things to check when you see an error message like this are:

- Make sure that the bit-level (either 32-bit or 64-bit) is the same for SCM Client, Java and Eclipse 
- If you have more than one copy of Java installed, make sure Eclipse is using the right one (check for JAVA_HOME system environment variable and that the version of java you want is at the front of the system path) 
- Make sure the system Path environment variable contains the path to the SCM Client software 
 
Resolution:
The user checked and found that the version of SCM Client was 32-bit and her Eclipse was 64-bit.  Installing the 32-bit version of Eclipse solved the problem in this case.