Harvest Client or Agent Only install stops at 94% when installing Enterprise Communicator (PEC) with message "Updating environment (Path)...."

Document ID : KB000055736
Last Modified Date : 14/02/2018
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Problem Description

Harvest Client or Agent Only install stops at 94% when installing Enterprise Communicator (PEC) with following message: "Updating environment (Path)..."

Possible Causes:

  1. Some active services conflict with the installation of PEC.
  2. PEC related system environment variables are already set or left from previous installation.
  3. System environment variable "Path" is too long or has more than 250 characters.
  4. PEC install directory has spaces in the directory name. For example: Program Files.

Corresponding Suggestions:

  1. Uninstall previous installation of Harvest client application and enterprise communicator before starting Harvest Client or Agent installation.
  2. Remove all PEC related environment variables like: RTHOME, RTARCH and all PEC entries from the PATH system variable.
  3. Ensure that Path system variable is not more than 250 characters in length.
  4. Try installing PEC separately from Harvest into a location with no spaces (such as: c:\pec).
  5. Say "No" to overwrite PEC install during Harvest Client or Agent install after point 4.
  6. Set your %TEMP% environment variable to a new location before running the install.
  7. Stop Blackberry and World Wide Web Publishing (IIS) services before beginning installation.