Global User Not Created in Provisioning

Document ID : KB000117028
Last Modified Date : 05/10/2018
Show Technical Document Details
Issue:
We have migrated our system from IAM R12.6 SP4 to Vapp R14.2.
However, an attempt to create a new global user (by assigning a provisioning role) is silently failing. There is no error in the log but new global users are not being created.
If a global user is already in place, then updates from IM are correctly reflected for any mapped attribute
Environment:
IM 14.x - Especially when utilizing the built-in identityEnv IME
Cause:
Attribute mapping (Corporate : Provisioning) is pointing to non existing attributes
Resolution:
Inspect the application server log during service startup and look for a similar error

ERROR [im.plugins.IMEnvironmentInitializerPlugin] (Thread-123(HornetQ-client-global-threads-1557331110)) Exception in configuring Auto Inbound: This method requires the presence of an attribute which was not provided. The attribute is named %DELEGATORS%.: AttributeNotPresentException: This method requires the presence of an attribute which was not provided. The attribute is named %DELEGATORS%.

In the above example, it seems as though the default mapping is not configured right (as %DELEGATORS% was not defined in the Prov XML)
Removing the mapping allowed Global Users to be created as expected.
To remove the mapping of the relevant attribute we need to utilize the IM Management Console > Environment > Advanced Settings > Provisioning and remove the incorrect / missing mapping