GIS View Error -- For Development Purposes only

Document ID : KB000113457
Last Modified Date : 10/09/2018
Show Technical Document Details
Issue:
Problem / Error: The client called in and told that already created a map for GIS field map. Google map shows for 'Development purpose only'.

Enabling the debug (F12) shows:

"You have exceeded your request quota for this API"

 
Resolution:
The Old APIKey you created needs to be replaced.

You need to create a new APIKey using the following link:

1. Open the following link and perform the request of the API Key:
 https://console.developers.google.com/flows/enableapi?apiid=maps_backend,static_maps_backend,geocoding_backend,directions_backend,distance_matrix_backend,elevation_backend,roads,street_view_image_backend,maps_embed_backend,places_backend,geolocation,timezone_backend,maps_android_backend,maps_ios_backend,placesandroid,placesios&keyType=CLIENT_SIDE&reusekey=true
2. In Oneclick server, open the "$SPECROOT\tomcat\webapps\spectrum\console\googleAPIKEY.config" file and configure the lines as below:
UseLicense=Yes 
API_KEY=<old api key>
Replace "<old api key>" with the API key obtained from Google in Step 1 above.
3. Save the file.