GigaStor Connector Not Processing Trace Files

Document ID : KB000100948
Last Modified Date : 12/06/2018
Show Technical Document Details
Issue:
After upgrading to the 11.0.2 GigaStor connector, data is not reaching the ADA console.

When we look on the GigaStor, we see large pcap files in C:\traces that are not being processed by the ADA connector.
Environment:
Windows 7, 10
Windows Server 2012
Cause:
The GigaStor connector has difficulty processing files larger than 20GB in a viable time frame. If the GigaStor is collecting a significant amount of data, the .pcap files in C:\traces can grow to 80GB or more.
Resolution:
To remedy the issue, we will reduce the trace file duration. This will generate smaller PCAP files, but more of them, so the connector can process them more effectively.

Locate the following registry key on the GigaStor server:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\NetQoS\OBSERVER

The specific value we want to change is:

'GIGASTOR_FILE_DURATION'

By default, this will be set to '60'. Set it to '10'.

Restart the 'GigaStor Reader' service to commit the changes.