Getting 'SQL server is not available' error during SOI upgrade from 3.3 to 4.2

Document ID : KB000102780
Last Modified Date : 10/07/2018
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Issue:
When upgrading from SOI 3.3 CUM2 (ArcServe DR) to SOI 4.2, getting an error "Database Error - SQL server is not available"

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Environment:
SOI 3.3 CUM2
SOI Manager & UI running on separate Windows Machines
SQL 2012 with SAMStore DB is running on remote server
Cause:
Cause 1:
=======
Following errors may found in "%TEMP%\CA-SOI_InstallDebug.log"
File D:\CA\SOI\resources\Configurations\SSA_IFW_HostName.xml not found -- Check for remote!
Loading IFW configuration from SSA_IFW_HostName.domain.net.xml
java.lang.NullPointerException
    at java.io.OutputStream.write(OutputStream.java:75)
    at com.ca.sam.util.Encryptor.decrypt(Encryptor.java:278)

From above exception, it complains that "samuser" password in \SSA_IFW_HostName.domain.net.xml is incorrect

Cause 2:
=======
Following errors may found in "%TEMP%\CA-SOI_InstallDebug.log"
com.ca.soi.config.EEM getProperties
SEVERE: Decrypting EEM password: null
java.lang.NullPointerException
    at java.io.OutputStream.write(OutputStream.java:75)
    at com.ca.sam.util.Encryptor.decrypt(Encryptor.java:278)

This indicating problem with EEM user password in \SOI\tomcat\custom or \SOI\tomcat\webapps\sam folder
Resolution:
Solution for Cause 1:
================
1) From above log, the problem is with "samuser" password and it is incorrect, hence it is unable to parse this file. So, we need generate a new encrypted password using "EncryptSAMCreds.bat" and updated in both \SOI\resources\configurations\SSA_IFW_HostName-domain.net.xml and "mtc_HostName-domain.net.xml" files 

Ex: EncryptSAMCreds.bat <samuser password> (from \SOI\Tools command prompt)

2) Since this SOI 3.3 is running on ArcServe D(SOI 4.2 doesn't support DR) disable 2nd SOI Manager DR entry in "SSA_IFW_HostName-domain.net.xml" as mentioned in 3.3 Wiki 

https://docops.ca.com/ca-service-operations-insight/3-3/en/installing/high-availability-implementation/non-cluster-high-availability-implementation/how-to-upgrade-from-a-previous-non-cluster-high-availability-environment 

Solution for Cause 2:
================
The eem-config.xml file located at 2 locations,
       => \SOI\tomcat\custom
       => \SOI\tomcat\webapps\sam

1) If the encrypted password string is incorrect in one of the above files, Upgrade | Installer cannot proceed
2) Copy encrypted password string from 1st file to second file or generate new encrypted password using "EncryptSAMCreds.bat" and then update this in both files
3) Re-run the installer

With above changes, now upgrade will continue and Manager will be upgraded to 4.2 version