Getting java.lang.NullPointerException errors in APM 10.0.1 Wily CTG agent log.

Document ID : KB000008300
Last Modified Date : 14/02/2018
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Issue:

 APM java agent (10.0.1 with CTG PowerPack enabled) repeatedly shows the following Exception in agent log file:

 java.lang.NullPointerException                                                                                                     
  at com.ibm.ctg.server.ServerECIRequestTracer.extract_Server_Name_From_Rcvd_ClientRequest(ServerECIRequestTracer.java:205)         
  at com.ibm.ctg.server.ServerECIRequestTracer.ITracer_startTrace(ServerECIRequestTracer.java:322)                                  
  at com.wily.introscope.agent.trace.InvocationData.IMethodTracer_startTrace(InvocationData.java:1342)                              
  at com.wily.introscope.agent.trace.TracerAdministrator.loadTracer(TracerAdministrator.java:304)                                   
  at com.wily.introscope.agent.enterprise.EnterpriseAgent.IAgent_loadTracer(EnterpriseAgent.java:962)                               
  at com.wily.introscope.agent.AgentShim.ProbeBuilderEntryPoint_loadTracer(AgentShim.java:1184)                                     
  at com.ibm.ctg.server.ServerECIRequest.executeECI(Unknown Source)                                                                 
  at com.ibm.ctg.server.ServerECIRequest.execute(Unknown Source)                                                                    
  at com.ibm.ctg.server.Worker.run(Unknown Source)                                                                                  
  at java.lang.Thread.run(Thread.java:785)               

Environment:
OS: z/OS 02.02.00 CTG Server JRE 1.8.0 IBM J9 2.8 z/OS s390x-64 Compressed Reference Agent Release 10.1.0.15 The APM Agent is using PPCTGServer-full.pbd.
Cause:

 CTG Client is sending an ECI request to the CTG server with a not populated "Server" field. Due to refactoring introduced in 2/2012 with the APM agent using the CTG PP, the CTG PP code is sensitive to this. Thus, APM agent is getting the Exception.

Resolution:

 1. Stop APM agent.

 2. Make a backup copy of agent profile.

 3. Edit the agent profile as follows:

 4. Replace PPCTGServer-full.pbd with PPCTGServer-typical.pbd in the following property in the Agent profile. 
    introscope.autoprobe.directivesFile

 5. Start APM agent.