Getting error message in popup when going into UMP

Document ID : KB000006745
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

When opening up USM on a new 8.5.1 install we see the following stack trace.

Furthermore, we are unable to see alarm data in the alarm view.

 

Details:
com.firehunter.ump.exceptions.DataFactoryException : com.esotericsoftware.kryo.KryoException: java.lang.IndexOutOfBoundsException: Index: 70, Size: 23
Serialization trace:
probeName (com.nimsoft.events.api.model.Alarm)
alarms (com.nimsoft.events.api.model.AlarmsResult)
Please check the log for more information.
Stack Trace:

Cause:

When navigating to  http://(umpserver)/usm/jsp/diag.jsp we saw

Version

USM Portlet:
Version = 8.5.1
Build Label = UMP_851_DEVELOPMENT
Build Date = February 1, 2017 5:31:25 AM PST
Build Number = 149484
Required Product Version = 8.5.0
User

USM Portlet:  Version                  = 8.5.1  Build Label              = UMP_851_GA  Build Date               = February 22, 2017 4:20:35 PM CST  Build Number             = 150087  Required Product Version = 8.5.0



Delete the usm package in the archive and redownload it from uimserverpackages.zip

Once that is completed

Disable WASP and do the following.
Delete the /webapps/usm AND /webapps/usm.war
Delete wasp/work folder and redeploy ump_usm.
Activate wasp and clear your browser cache from the beginning of time.

The issue should be resolved

It appears the version you're using for USM webapp is the beta - not sure why.

What you should have saw in that URL was...

USM Portlet:
Version = 8.5.1
Build Label = UMP_851_GA
Build Date = February 22, 2017 5:20:35 PM EST

 

Somehow, the wrong version of USM was installed.

Resolution:

To resolve;

  1. Disable the UMP WASP probe
  2. Delete the nimsoft/probes/service/webapps/usm AND nimsoft/probes/service/webapps/usm.war on the UMP machine
  3. Delete wasp/work folder and redeploy ump_usm.
  4. Activate wasp and clear the browser cache from the beginning of time.