FTP JOB fails with error - 501 PORT IP is not same as ...

Document ID : KB000009168
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

I am trying to download a file from a vendor FTP using native FTP job and getting the following error:

501 PORT IP is not same as ***.xx.***.250.
Download failed: "PORT is unsuccessful"
Logged out

Environment:
CA Workload Automation System Agent 11.3.x on all supported platforms.
Cause:

The "PORT" command is part of the Active FTP mode connection and it requires the FTP Client (CA WA System Agent / FTP job) to share its IP Address to the external FTP Server. It is probably that the CA WA Agent is sharing its local address (intranet) with the FTP server, but connects using its external IP address (***.xx.***.250) and FTP server does not like the mismatch (external vs local).

Resolution:

To enable Passive FTP connection, update the following System Agent parameter in the agentparm.txt file on the CA WA Agent that runs the FTP job and restart the System Agent.

ftp.passive=true

From CA Workload Automation Agent DocOps:

  • ftp.passive
    Specifies whether the agent FTP client uses a passive mode connection, as follows:
    • true
      Indicates that the agent uses a passive mode connection.
    • false
      Indicates that the agent uses an active mode connection.

    Default: false

    Note: We recommend that you set the value to true under any of the following conditions:
    • The agent uses IPV4 and the FTP server uses IPV6 for communication.
    • The FTP server resides beyond the firewall.
    • The FTP server opens a listening port for the data channel.