Following upgrade of CA Datacom/DB to version 15.0, DDSDCLM program with VERIFY command produces DDPDE30001 ENCRYPTION NOT ALLOWED W/O RECOVERY

Document ID : KB000033576
Last Modified Date : 14/02/2018
Show Technical Document Details

Problem:

Following an upgrade of CA Datacom/DB to version 15.0, running the Datadictionary Comparator program (DDSDCLM) with the VERIFY command can produce error message

DDPDE30001 ENCRYPTION NOT ALLOWED W/O RECOVERY

This is confusing for users who ran the same program with the SDC command before the upgrade to ensure the readiness of the Datadictionary, but that did not produce any error.

Environment: 

This applies to CA Datacom/DB version 15.0 for z/OS.

Cause:

The situation leading to this error message could be the result of problems during the upgrade to version 15.0, or to a previous version upgrade. As the encryption/recovery values are not critical to the upgrade process itself, the SDC command does not check for them before an upgrade.

Resolution/Workaround:

There is a solution for version 15.0 that should be applied to resolve these errors.

RO86854 (DD 15.0 #34), "SKIP DATA ENCRYPTION EDITS FOR UPDVERFY FOR 15.0"

As always, please contact CA Technologies support for CA Datacom if you have further questions.