File Transfer fails if Agent versions do not match

Document ID : KB000087406
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
U2000049 The routine 'UCFTXEX' received unknown message type 'FTXSENDQ'.

When Agent versions involved in a file transfer job do not match, transfers will complete but the job will display in a status of  'Active' indefinitely.

Example:

This can happen if the sending agent is Windows v11.2 and the destination agent is Linux v10.0.8.

When this happens the above error message can be seen in the agent log.

Environment:
OS: All
OS Version: N/A
Cause:
Cause type:
By design
Root Cause: To/From Agent versions must match when doing a File Transfer.
Resolution:
Ensure that the Agents used in the file transfer are both on the same version.

In the example given in the description, the v10.0.8 Agent would need to be upgraded to v11.2 before the file transfer would complete successfully.

In general, a good practice is to make sure all the agents are the same version. This will help eliminate this issue along with other potential issues.


Fix Status: No Fix

Fix Version(s):
N/A
Additional Information:
Workaround :
N/A