Federation throwing 500 Server error after IP change to Policy servers

Document ID : KB000096870
Last Modified Date : 06/06/2018
Show Technical Document Details
Issue:
Our SiteMinder Policy servers were moved to a different datacenter and got new IPs, we changed the SMHost.conf but agent is still throwing 500 errors.
Cause:
Logs were showing that the LLAWP service was receiving the ACO and HCO objects, but was failing to make a connection to the Policy Servers.


[2688/2708][Wed May 16 2018 13:13:45][agentcommon][INFO][sm-FedClient-00010] Administration Manager is trying to create configuration for the SiteMinder Agent
[2688/2708][Wed May 16 2018 13:13:45][agentcommon][INFO][sm-FedClient-00010] Creating agent connection using file : <redacted>\WebAgent.conf
[2688/2708][Wed May 16 2018 13:13:51][agentcommon][INFO][sm-FedClient-00010] Registering the Configuration Manager with the Policy Server
[2688/2708][Wed May 16 2018 13:13:53][agentcommon][INFO][sm-FedClient-00010] The doManagement Thread failed as the Policy Server could not be reached. Reason: Agent API No Connection
[2688/2708][Wed May 16 2018 13:13:54][FWSAdministrationManager.java][ERROR][sm-FedClient-00050] Error initializing Federation Web Services: Failed to create agent configuration for : <redacted>\WebAgent.conf
[2688/2708][Wed May 16 2018 13:13:54][FWSAdministrationManager.java][ERROR][sm-FedClient-00060] Federation Web services initialization FAILED. ()
[2688/2708][Wed May 16 2018 13:13:54][ManageNameIDService.java][INFO][sm-FedClient-01520] SAML2 NameID Management Service has been successfully initialized.
Resolution:
HCO needed to be updated with correct IP addresses.