Federation Security Services compatibility

Document ID : KB000013667
Last Modified Date : 14/02/2018
Show Technical Document Details
Introduction:

We are planning a migration from R12 SP3 to R12.52 and have a question regarding the upgrade steps, specifically for FSS. We currently have a number of very active federation partnerships and would like to know if federation will continue to work during the interim period where Policy Servers have been upgraded to R12.52 but WebAgents+Option Pack are still R12SP3?  Can you provide guidance on the transition of FSS during an upgrade?

Question:

Will federation continue to work during the interim period where Policy Servers have been upgraded to R12.52 but WebAgents+Option Pack are still R12SP3?

Answer:

The 12.52 Policy Server is backward compatible with the 12.x agent and agent option pack. Regarding the FSSUI, once you have upgraded the Policy Server, Policy Store, and AdminUI do not use the FSS UI as you could corrupt your policy store. All of the functionality that was in the 12.x FSSUI has been incorporated into the 12.52 AdminUI. 

Here is a link to the 12.52-SP1 SiteMinder Upgrade Guide: https://docops.ca.com/ca-single-sign-on-12-52-sp1/en/upgrading 

Here is a link to the 12.52-SP1 Bookshelf: https://docops.ca.com/ca-single-sign-on-12-52-sp1/en