FATAL error in the reconciliation message queue, and our assets are not matched or reconciled

Document ID : KB000008663
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

We are receiving these messages in the reconciliation message queue:

FATAL CA.Applications.HardwareReconciliation.Engine - Asset Match Processing Error: You can only specify the READPAST lock in the READ COMMITTED or REPEATABLE READ isolation levels.

Our assets are not reconciling or matching and the 'Asset Viewer - Discovered information' link is not present on the asset. 

 

Environment:
CA Asset Portfolio Management 17.0
Cause:

This is a known issue in the CA APM 17.0 GA release. 

Resolution:

Contact support for an updated stored procedure named:  AL_SP_GET_MATCH_QUERY_SN_HN.sql

Also, this correction is planned for inclusion in the APM 17.0 #1 Rollup patch