Fast Data Masker error: THIS DRIVER IS NOT CONFIGURED FOR INTEGRATED AUTHENTICATION

Document ID : KB000006552
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Fast Data Masker throws following error while connecting to SQL Server Database:

THIS DRIVER IS NOT CONFIGURED FOR INTEGRATED AUTHENTICATION. 

CLIENTCONNECTIONID:XXXXXX-XXXX-XXXX-XXXX-XXXXXX

Environment:
Running Fast Data Masker GA version for Test Data Manager 4.x releases
Cause:

It might fail if the Driver JAR and Auth DLL are not compatible. Hence we need to make sure that we get compatible version of SQL Server JAR and Auth DLL.

Resolution:

We need to make sure that we get compatible version of SQL Server JAR and Auth DLL. Below are the links to check compatibility and download the Drivers. 

Compatibility matrix - https://docs.microsoft.com/en-us/sql/connect/jdbc/microsoft-jdbc-driver-for-sql-server-support-matrix  

Drivers - https://docs.microsoft.com/en-us/sql/connect/jdbc/download-microsoft-jdbc-driver-for-sql-server  

When using "Microsoft JDBC Driver 4.0 for SQL Server", "sqljdbc4.jar", and 64 bit version of "sqljdbc_auth.dll" in auth folder, it should work.

Additional Information:

If you are still experiencing this error message, please also review this knowledge document https://support.ca.com/us/knowledge-base-articles.TEC1369915.html.