Failure to upgrade CA Directory 12.0.18 to 12.6.03 using the RPM installer

Document ID : KB000016068
Last Modified Date : 14/02/2018
Show Technical Document Details
Question:

When upgrading CA Directory to 12.6.03 using the RPM package, CA Directory errors out with "The DSA has failed to respond to the 'dxserver stop' command". How can this error be prevented and proceed with the upgrade?

Answer:

During the RPM install for CA Directory, if the base version is 12.0.18 and upgrading to desired version of 12.6.03. The installer is expecting the comment 'DXserver Administrator' for the user. To avoid this, please run this command:

rpm -e --nopreun cadirectory-12.0.18-12074 'dsa' user would remain intact after the above command. Then install newer package:
rpm -i --replacepkgs cadirectory-12.6.03-14056.x86_64.rpm