Failure Message When Attempting to Sync Account Plans

Document ID : KB000044555
Last Modified Date : 14/02/2018
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Issue: 

Clicking on "Sync Account Plans" within the Layer 7 Gateway plugin of the API Developer Portal results in the following failure message (the GUID value is an example and can vary):        

<Failure message="Failed Fragment Validation: GUID 14f288d5-f212-4626-afe6-b3957d10d830 does not exist" code="500"/>

Environment:  

All versions of the API Developer Portal can be affected by this.

Cause: 

This error is a result of a mismatch of GUIDs between the Account Plans Policy Fragment and the value for the Cluster-Wide Property titled portal.account.plans.fragment.guid.

Resolution:

1. Login to the Policy Manager

2. Right click on "Account Plans Fragment" and click "Policy Properties"

3. Copy the value of "Policy GUID"

4. Click on "Tasks" > "Manage Cluster-Wide Properties"

5. Open the cluster-wide property titled: portal.account.plans.fragment.guid

6. Ensure that the value of this cluster-wide property matches the value from Step 3. If it doesn't match, replace the value in the cluster-wide property with the value from step 3. Ensure there is no trailing white space.

7. Click OK

8. Re-Test the "Sync Account Plans"