Failed to load DLL IEFCMN, reason code 126

Document ID : KB000110651
Last Modified Date : 10/08/2018
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Issue:
Client Manager (CM) will not start correctly after upgrade.
Environment:
Windows 7, Windows 10
Cause:
We are using own Install shield and after upgrade and start Client Manager (CM) failed with error 'Failed to load DLL IEFCMN, reason code 126. When I send test transaction, it works OK but displays the message "Message load failure, id = 16034, error 1813" 

 
Resolution:
1-check the PATH settings in WINDOWS>Enviroment settings
2-is your CM deployment directory in the system path? 
3-check your iefcmn.ini file 
4-check the path of MSGDLLNAME is set to

correct all the PATH settings will solve this, in this case it was the incorrect path of MSDLLNAME
Additional Information:
https://docops.ca.com/ca-gen/8-6/en/middleware/working-with-the-client-manager/configuring-the-client-manager-for-client-communications